Wilkommen, Bienvenu, Welcome... Sziasztok!

Welcome to The Lotus Position, an intermittent collection of extempore navel gazings, ponderings, whinges, whines, pontifications and diatribes.

Everything is based on a Sample of One: these are my views, my experiences... caveat lector... read the Disclaimer

The Budapest Office - Castro Bisztro, Madach ter

The Budapest Office - Castro Bisztro, Madach ter
Ponder, Scribble, Ponder (Photo Erdotahi Aron)

Guest Nutter/Kindred Soul: Bill Bailey

Loading...

Wednesday, 22 December 2010

Excel... "the clipboard cannot be emptied" - a solution

I say "a solution" advisedly: Excel warns that another application may be using the clipboard - thereby preventing it being cleared (because e.g. the other application has "locked" the clipbaord.) But even if it were true, how does one identify the offending app? The hard way... quitting them one by one and seeing when the fault goes away. As a result of which I found an offender: the Skype add-on for Firefox - and whilst other applications have also been noted as being at fault, the only one I had previously noted was rther more obscure than Skype.

I had tried all sorts of cleverness (such as adding DWORD AcbPreventPreemptiveCollect = 1 to HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common\General; checking that rdpclip wasn't running; worrying about the VM integration features of Windows 7's XP Mode, etc.), none of which worked, and then for some reason just thought I'd be methodical with the only other major app that was running - FireFox.

I restarted it in safe mode and the Excel error (which actually only affected Drag and Drop, rather than cut and paste per se) disappeared. I then went through the Add-ons disabling all and re-enabling one by one until the culprit was found. To be honest, I had expected the Adobe Reader plug in to be at fault, but it wasn't.

Hope that helps lots of people with various clipboard problems in various versions of Excel and various Microsoft operating systems.

5 comments:

Anonymous said...

Many thanks to you, this indeed was the solution to this problem, which I started experiencing a couple of days ago. I'll try to inform the Skype folks of the problem.

Richard said...

If NovaPDF (or similar) is installed then uninstalling it works.

Mike Stankavich said...

Dude, you just saved me hours of tail-chasing insanity. I don't like that Skype add-on anyway, but just hadn't bothered to kill it after reinstalling Skype. Thanks for sharing. Much appreciated.

Best, Mike

Phil B said...

Thanks for this tip. Was having the same problem in Excel 2010 under Windows 7. I uninstalled the Skype Toolbars (but left the main Skype program installed), and the problem went away instantly. Much happier now :-D

Jan Frederik said...

Thanks a lot! Finally I got rid of this annoying message...